欢迎光临
我们一直在努力

VXLAN技术3和SDN基础概念

 

VXLAN技术,不同子网之间的vxlan配置。

Vxlan,点对点的隧道技术。

虚拟化的情况下,基于虚拟化租户迁移的情况,实现IP地址不变。

1.集中式网关GW部署

 

隧道配置指定中间节点网关。

使192.168.1.10与192.168.2.10互通。

GW配置如下:

#

interface GE1/0/0

undo portswitch

undo shutdown

ip address 10.1.1.1 255.255.255.0

interface GE1/0/1

undo portswitch

undo shutdown

ip address 20.1.1.1 255.255.255.0

interface LoopBack0

ip address 2.2.2.2 255.255.255.0

#

ospf 100 router-id 2.2.2.2

area 0.0.0.0

network 2.2.2.0 0.0.0.255

network 10.1.1.0 0.0.0.255

network 20.1.1.0 0.0.0.255

#

bridge-domain 1000

vxlan vni 1000

bridge-domain 2000

vxlan vni 2000

#

interface Nve1

source 2.2.2.2

vni 1000 head-end peer-list 1.1.1.1

vni 2000 head-end peer-list 3.3.3.3

#

interface Vbdif1000

ip address 192.168.1.1 255.255.255.0

interface Vbdif2000

ip address 192.168.2.1 255.255.255.0

#

 

2.分布式GW部署

两个分布式网关之间通过BGP承载,叫做EVPN。

组网-CE2—CE1—CE3,CE2与CE3作为分布式网关,互相学习彼此的主机路由信息。

注意,建立IBGP邻居,在中间设备需开启RR功能,并关于RT值的严格检查

===CE2===

ip vpn-instance site1

ipv4-family

route-distinguisher 2:2

vpn-target 20:20 import-extcommunity evpn

vpn-target 22:22 import-extcommunity evpn

vxlan vni 99

—配置VPN实例,用于三层通信—

bgp 100

peer 1.1.1.1 as-number 100

peer 1.1.1.1 connect-interface LoopBack1

ipv4-family unicast

peer 1.1.1.1 enable

ipv4-family vpnv4

policy vpn-target

peer 1.1.1.1 enable

l2vpn-family evpn

policy vpn-target

peer 1.1.1.1 enable

peer 1.1.1.1 advertise irb

—配置基于BGP的EVPN—

bridge-domain 10

vxlan vni 10

evpn

route-distinguisher 2:2

vpn-target 20:20 export-extcommunity

vpn-target 20:20 import-extcommunity

bridge-domain 20

vxlan vni 20

evpn

route-distinguisher 20:20

vpn-target 22:22 export-extcommunity

vpn-target 22:22 import-extcommunity

—配置BD,绑定RT值—

interface GE1/0/1.10 mode l2

encapsulation dot1q vid 10

bridge-domain 10

interface GE1/0/1.20 mode l2

encapsulation dot1q vid 20

bridge-domain 20

interface Vbdif10

ip binding vpn-instance site1

ip address 192.168.1.1 255.255.255.0

arp distribute-gateway enable

arp collect host enable

interface Vbdif20

ip binding vpn-instance site1

ip address 192.168.2.1 255.255.255.0

arp distribute-gateway enable

arp collect host enable

—子接口和三层接口配置,需开启分布式网关功能并且学习主机路由信息—

CE3描述和CE2一致,此时不再赘述

ip vpn-instance site1

ipv4-family

route-distinguisher 2:2

vpn-target 20:20 import-extcommunity evpn

vpn-target 22:22 import-extcommunity evpn

vxlan vni 99

——————————————————

bgp 100

peer 1.1.1.1 as-number 100

peer 1.1.1.1 connect-interface LoopBack1

ipv4-family unicast

peer 1.1.1.1 enable

ipv4-family vpnv4

policy vpn-target

peer 1.1.1.1 enable

l2vpn-family evpn

policy vpn-target

peer 1.1.1.1 enable

peer 1.1.1.1 advertise irb

———————————————–

bridge-domain 10

vxlan vni 10

evpn

route-distinguisher 2:2

vpn-target 20:20 export-extcommunity

vpn-target 20:20 import-extcommunity

bridge-domain 20

vxlan vni 20

evpn

route-distinguisher 20:20

vpn-target 22:22 export-extcommunity

vpn-target 22:22 import-extcommunity

—————————————————

interface GE1/0/1.10 mode l2

encapsulation dot1q vid 10

bridge-domain 10

interface GE1/0/1.20 mode l2

encapsulation dot1q vid 20

bridge-domain 20

interface Vbdif10

ip binding vpn-instance site1

ip address 192.168.1.1 255.255.255.0

arp distribute-gateway enable

arp collect host enable

interface Vbdif20

ip binding vpn-instance site1

ip address 192.168.2.1 255.255.255.0

arp distribute-gateway enable

arp collect host enable

=============================

CE1的配置

=============================

bgp 100

peer 2.2.2.2 as-number 100

peer 2.2.2.2 connect-interface LoopBack1

peer 3.3.3.3 as-number 100

peer 3.3.3.3 connect-interface LoopBack1

ipv4-family unicast

dampening

peer 2.2.2.2 enable

peer 3.3.3.3 enable

ipv4-family vpnv4

undo policy vpn-target

peer 2.2.2.2 enable

peer 2.2.2.2 reflect-client

peer 3.3.3.3 enable

peer 3.3.3.3 reflect-client

l2vpn-family evpn

undo policy vpn-target

peer 2.2.2.2 enable

peer 2.2.2.2 advertise irb

peer 2.2.2.2 reflect-client

peer 3.3.3.3 enable

peer 3.3.3.3 advertise irb

peer 3.3.3.3 reflect-client

 

 

SDN软件定义网络

一台网络设备,需要在里面做配置,数据经过设备转发。

做配置,设备运行OSPF ISIS BGP等,这些是控制层面的东西。比如看到的路由表。

数据做转发,查询FIB表转发下一跳,这是转发层面。

思科-DNA,思科对于企业端SDN解决方案。

华为-AC,agile controller,敏捷控制器。

SDN就是一个服务器,在服务器的环境下,部署SDN控制器,上边系统是Linux,部署SDN自动化功能。

SDN是一种集成化的解决方案。各项功能,组合到一起去。

Vxlan的技术原理很像tunnel隧道,基于BGP承载,underlay-基于OSPF,ISIS.

LLDP用来检测连接设备的拓扑图,逻辑拓扑。

所以SDN是一个综合解决方案。

Openflow,南向协议-下发流表-下方转发器不需要,进行任何协议开启。

NETCONF,南向协议-下发配置-不能下发流表。

RESTful,北向协议。

SDN自动化部署下发配置,下发流表openflow,更方便的管理下游设备,监控每个设备里边的各种表项,实时发现拓扑变化,监控设备里的种种信息,观察设备变化,故障,变更等。即插即用(设备接上自动上线),自动排错。

赞(2) 打赏
未经允许不得转载:知行合一 » VXLAN技术3和SDN基础概念
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

知行合一

清华大学万门大学

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏